فهرست بستن

میلیون‌ها وب‌سایت از سال آینده نمی‌توانند در دستگاه‌های اندرویدی قدیمی دیده شوند؛ اما چگونه این باگ را رفع کنیم؟

گواهینامه SSL برای سایت‌ها اهمیت بسیار بالایی دارد؛ چون از آن‌ها در برابر حملات اینترنتی و سرقت اطلاعات کاربران در جابه‌جایی‌ها و تراکنش‌های مالی جلوگیری می‌کند.

براساس گزارش گوگل، اکنون ۹۵ درصد ترافیک اینترنت به صورت رمزنگاری شده است.

Let’s Encrypt یکی از مراکز صادرکننده گواهی‌نامه HTTPS برای سایت‌ها است تا مطمئن شود ترافیک این وب‌سایت‌ها از یک مسیر امن منتقل می‌شود. این سازمان تا کنون بیش از یک میلیارد گواهی‌نامه برای بیش از ۱۹۲ میلیون وب‌سایت صادر کرده است.

چون چندین مرکز صادرکننده گواهی‌نامه‌های SSL در اینترنت وجود دارد؛ اگر مرورگر وب شما از یک گواهی‌نامه خاص پشتیبانی نکند؛ ممکن است برخی سایت‌ها با مشکلات عدم سازگاری روبرو شوند و لود نشوند.

این دقیقا مشکلی است که در انتظار دستگاه‌هایی با اندروید ۷.۱.۱ و قبل‌تر است و به‌زودی با آن روبرو خواهند شد.

هنگامی که مرکز Let’s Encrypt در سال ۲۰۱۵ راه‌اندازی شد؛ به غیر از گواهی‌نامه ریشه خود، از گواهی‌نامه‌های مرکز دیگری به نام IdenTrust نیز استفاده کرد. حالا، همکاری بین این دو مرکز در تاریخ ۱ سپتامبر ۲۰۲۱ به پایان می‌رسد و Let’s Encrypt برای تایید اعتبار وب‌سایت‌ها فقط از گواهی‌نامه‌های خودش استفاده می‌کند.

Let’s Encrypt در حال برداشتن‌های گام‌های مقدماتی و تغییر API برای استفاده از گواهی‌نامه‌های پیش‌فرض خودش از ۱۱ ژانویه است.

راه‌حل: استفاده از مرورگر فایرفاکس

اما این مسئله در دستگاه‌های اندرویدی قدیمی از جمله آن‌هایی که مبتنی بر اندروید ۷.۱.۱ و قبل‌تر هستند؛ مشکل ایجاد خواهد کرد. این دستگاه‌ها برای تایید گواهی‌نامه‌های ریشه Let’s Encrypt به‌روز نشدند و همچنان گواهی‌نامه‌های مستقل از پلتفرم IdenTrust را معتبر می‌دانند.

این عدم سازگاری می‌تواند باعث بروز برخی مشکلات شود. برخی از نرم‌افزارهایی که از سال ۲۰۱۶ به این طرف به‌روزرسانی نشده‌اند؛ نمی‌توانند گواهی‌نامه ریشه ISRG Root X1 را تایید کنند. از جمله این برنامه‌های می‌توان به نسخه‌های اندروید ۷.۱.۱ و قبل‌تر از آن اشاره کرد. این دستگاه‌ها نمی‌توانند گواهی‌نامه Let’s Encrypt را تایید اعتبار کنند.

موسسه Let’s Encrypt می‌گوید به طور واضح، اپلیکیشن‌های قدیمی‌تر که مبتنی بر گواهی‌نامه‌های گذشته هستند؛ نمی‌توانند با این به‌روزرسانی اخیر سازگاری داشته باشند.

براساس آماری که از موسسه صدور گواهی‌نامه Android Studio گرفته شده است؛ بیش از ۳۴ درصد دستگاه‌های اندرویدی در سراسر جهان هنوز اندروید ۷.۱ و پایین‌تر را اجرا می‌کنند. این دستگاه‌ها پس از ماه ژانویه ۲۰۲۱ ممکن است قادر به اجرا و باز کردن برخی وب‌سایت‌ها و سرویس‌های مبتنی بر وب نباشند.

سایت اندروید پلیس می‌گوید، راه‌حل رفع این باگ و فرار از مشکلات عدم سازگاری گواهی‌نامه‌های SSL، نصب مرورگر وب موزیلا فایرفاکس روی این دستگاه‌ها است. فایرفاکس از گواهی‌نامه‌های ریشه برای تایید اعتبار وب‌سایت‌ها استفاده می‌کند.

Let’s block ads! (Why?)

لینک منبع

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *